OnLine Banking FAQ's & Troubleshooting

At The Bank of Holland we constantly work to provide the best OnLine Banking products. Recent improvements have raised some issues as this updated version of OnLine Banking requires newer software to run as intended.

The new requirements are listed below along with some basic troubleshooting tips. Detailed troubleshooting tips are available for download on the right side of the screen.

Recommended System Requirements:

  • Supported Operating Systems: Windows XP SP3, Windows Vista, Windows 7 and Mac OSX.
  • Supported Browsers: Microsoft Internet Explorer 7, 8 or 9; Mozilla Firefox 4; Opera 10; Google Chrome; or Safari 5.
  • Supported PDF Readers: Adobe Acrobat 10 or Adobe Reader 10. Download the latest version of Adobe Reader here.
  • OnLine Banking is not affected by Java versions, ActiveX or popup blockers

PDF Viewer Issues

Can't see e-Statements? Download the latest version of Adobe Reader here.